Boid App Discussion - Windows Client

Any issues regarding boid app usage, installation, etc.

Dan’s Video about Installing and Troubleshooting:

Latest Boid Desktop App Version is 0.0.53 and you can download it from here:


No Valid GPU was found—swapped out a gpu today–after rebooting got that message–the same gpu pair on my other machine works fine–rx570 and rx 580–tried un installing and reinstalling boid app same error

it works fine if I run wildrig outside of boid app

I just created a new topic for windows and mac clients. Is your post regarding Windows?

also have you tried this reset option? and then restart the client

Yes the reset option should help to resolve this issue.

yes thx that worked–my bad for not seeing that option

I seem to be getting better hashrate when I run wildrig manually–if I run it manually will it still register its boid power as before

As long as your configuration is the same there is no difference. You can check what configuration the Boid app is using by looking at config.wildrig.json inside the .Boid/GPU/wildrig folder.

the main difference between config files are the opencl-threads- mine is set to auto–and the opencl-launch which mine is also set to auto. and there is no watchdog parameter and no donate parameter…The hashrate reported by the app really jumps around and is quite a bit lower than what is reported in wildrig console

I think when you set GPU Intensity inside the app to 100% then I should set the parameter to auto as that is probably more flexible for a wide range of GPU types. Currently It’s calibrated based on a specific GPU.

One think that you could try as a test @Manfred is to change the Boid config to auto. The app will not overwrite your modification unless you manually try to adjust the GPU intensity inside the app.

Likely if you change the Boid config to match the config you use outside the app you will see identical performance.

yes I thought about changing it to auto,wanted to check with you first… Il see if it makes a difference. The hashrate reported in boid app tends to change frequently–like every few seconds…while hardly ever changes in wildrig–ill let you know how it pans out, THX

Hey all. I had lot’s of trouble getting Wildrig working on Windows with AMD Radeon RX 580.
Everything noted above didn’t work for me. I am posting my solution here in support of the community;)

Here’s what I did to get it working:

  1. Download wildrig-multi-windows-0.28.3 and extracted it into …/.boid/gpu/wildrig
    (**noting that the default installer puts the executable in …/.boid/gpu/wildrig/wildrig - which is incorrect)

  2. Edit the boid-wildrig-config.json and remove this part: “–donate-level=1”

Restart Boid, all is well now.